<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html dir='ltr' xmlns='http://www.w3.org/1999/xhtml' xmlns:b='http://www.google.com/2005/gml/b' xmlns:data='http://www.google.com/2005/gml/data' xmlns:expr='http://www.google.com/2005/gml/expr'>
<head>
<link type='text/css' rel='stylesheet' href='https://www.blogger.com/static/v1/widgets/763856997-widget_css_bundle.css' />
<script async='' src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-7300728982462487",
    enable_page_level_ads: true
  });
</script>
<meta content='text/html; charset=UTF-8' http-equiv='Content-Type'/>
<meta content='blogger' name='generator'/>
<link href='http://www.sacralpanda.com/favicon.ico' rel='icon' type='image/x-icon'/>
<link href='http://www.sacralpanda.com/2017/08/how-to-become-python-coder-first-part.html' rel='canonical'/>
<link rel="alternate" type="application/atom+xml" title="sacralpanda - Atom" href="http://www.sacralpanda.com/feeds/posts/default" />
<link rel="alternate" type="application/rss+xml" title="sacralpanda - RSS" href="http://www.sacralpanda.com/feeds/posts/default?alt=rss" />
<link rel="service.post" type="application/atom+xml" title="sacralpanda - Atom" href="https://www.blogger.com/feeds/3019166093343777824/posts/default" />

<link rel="alternate" type="application/atom+xml" title="sacralpanda - Atom" href="http://www.sacralpanda.com/feeds/7647189486764722753/comments/default" />
<!--Can't find substitution for tag [blog.ieCssRetrofitLinks]-->
<link href='https://4.bp.blogspot.com/--kK4JVIv8wI/Vx5bqCL97OI/AAAAAAAABk4/5cwFvsWA77MTygYwmjXyllZbyRdIvtQugCLcB/s640/coding-640x356.jpg' rel='image_src'/>
<meta content='http://www.sacralpanda.com/2017/08/how-to-become-python-coder-first-part.html' property='og:url'/>
<meta content='How to become a python coder, first part' property='og:title'/>
<meta content='       What is python    Python is a high level computer programming language easy to learn and put in use by anyone who is passionate about...' property='og:description'/>
<meta content='https://4.bp.blogspot.com/--kK4JVIv8wI/Vx5bqCL97OI/AAAAAAAABk4/5cwFvsWA77MTygYwmjXyllZbyRdIvtQugCLcB/w1200-h630-p-k-no-nu/coding-640x356.jpg' property='og:image'/>
<!--[if IE]> <script> (function() { var html5 = ("abbr,article,aside,audio,canvas,datalist,details," + "figure,footer,header,hgroup,mark,menu,meter,nav,output," + "progress,section,time,video").split(','); for (var i = 0; i < html5.length; i++) { document.createElement(html5[i]); } try { document.execCommand('BackgroundImageCache', false, true); } catch(e) {} })(); </script> <![endif]-->
<title>How to become a python coder, first part - sacralpanda</title>
<!-- [ Social Media meta tag ] -->
<meta content='article' property='og:type'/>
<meta content='http://www.sacralpanda.com/2017/08/how-to-become-python-coder-first-part.html' property='og:url'/>
<meta content='https://4.bp.blogspot.com/--kK4JVIv8wI/Vx5bqCL97OI/AAAAAAAABk4/5cwFvsWA77MTygYwmjXyllZbyRdIvtQugCLcB/s640/coding-640x356.jpg' property='og:image'/>
<meta content='sacralpanda' property='og:site_name'/>
<meta content='en_US' property='og:locale'/>
<!-- Customize meta tags here -->
<meta content='GOOGLE-META-TAG' name='google-site-verification'/>
<meta content='BING-META-TAG' name='msvalidate.01'/>
<meta content='ALEXA-META-TAG' name='alexaVerifyID'/>
<meta content='width=device-width, initial-scale=1, minimum-scale=1, maximum-scale=1' name='viewport'/>
<link href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css' rel='stylesheet'/>
<script src='https://ajax.googleapis.com/ajax/libs/jquery/1.7.1/jquery.min.js' type='text/javascript'></script>
<link href='https://fonts.googleapis.com/css?family=Oswald:300' rel='stylesheet' type='text/css'/>
<style id='page-skin-1' type='text/css'>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</style>
<style type='text/css'>

.post-body h1 { font-size: 44px; line-height: 34px; margin: 10px 0; }
.post-body h2 { font-size: 24px; line-height: 40px; margin: 10px 0; }
.post-body h3 { font-size: 20px; line-height: 34px; margin: 10px 0; }
.post-body h4 { font-size: 26px; line-height: 36px; margin: 10px 0; }
.post-body h5 { font-size: 24px; line-height: 34px; margin: 10px 0; }
.post-body h6 { font-size: 18px; line-height: 24px; margin: 10px 0; }

.blog-pager, #blog-pager{border:1px solid #e6e6e6; padding:1em 0; margin:0;}

@media screen and (min-width: 240px){

}


@media screen and (min-width: 320px){

}


@media screen and (min-width: 1024px) {


}

</style>
<style type='text/css'>
.post-body ol,.post-body ul { padding: 10px 0 20px;  margin: 0 0 0 25px;  text-align: left;  }
.post-body ol li { list-style-type: decimal;  padding:0 0 5px;  }
.post-body ul li { list-style-type: square;  padding: 0 0 5px;  }
.post-body img{max-width:89%; height:auto;}
.title-secondary{float:left;}
</style>
<style type='text/css'>
.ct-wrapper{background:#fff;}
</style>
<script type='text/javascript'>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</script>
<script type='text/javascript'>
        (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
        ga('create', 'UA-39877849-9', 'auto', 'blogger');
        ga('blogger.send', 'pageview');
      </script>
<link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=3019166093343777824&amp;zx=04ffd29d-ade7-45d6-94d5-df7df674a56d' media='none' onload='if(media!=&#39;all&#39;)media=&#39;all&#39;' rel='stylesheet'/><noscript><link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=3019166093343777824&amp;zx=04ffd29d-ade7-45d6-94d5-df7df674a56d' rel='stylesheet'/></noscript>
</head>
<body class='loading'>
<div class='ct-wrapper'>
<div class='mage'>
<div class='top-nav'>
<div class='container'>
<div class='resp-desk1'><a href='#' id='duled1'><i class='fa fa-reorder'></i> Pages</a>
</div>
<ul class='Pagemenu'>
<!-- Customize Top Menu Here -->
<li><a class='home' href='http://www.sacralpanda.com/'>Home</a></li>
<li><a href='http://spiritualpanda.blogspot.al/p/who-is-spiritual-panda.html'>About</a></li>
<li><a href='/p/privacy-policy_19.html'>Privacy Policy</a></li>
<li><a href='/p/contact-us_19.html'>Contact us</a></li>
</ul>
<div class='social-ico'>
<!-- Social Profile Icons -->
<a class='tt1' href='https://www.facebook.com/Sacralpanda-131016297498635/' rel='nofollow' title='Like us'><i class='fa fa-facebook'></i></a>
<a class='tt2' href='YOUR-GOOGLE+-URL' rel='nofollow' title='Add to circle'><i class='fa fa-google-plus'></i></a>
<a class='tt3' href='YOUR-TWITTER-URL' rel='nofollow' title='Follow us'><i class='fa fa-twitter'></i></a>
<a class='tt4' href='RSS-FEED-URL' rel='nofollow' title='Rss feeds'><i class='fa fa-rss'></i></a>
</div>
</div>
</div>
</div><!-- mage -->
<div class='clear'></div>
<div class='container'>
<div class='header-wrapper'>
<div class='header-inner-wrap'>
<div class='header section' id='header'><div class='widget Header' data-version='1' id='Header1'>
<div id='header-inner'>
<div class='titlewrapper'>
<h2 class='title'>
<a href='http://www.sacralpanda.com/' itemprop='url' title='sacralpanda'>
<span itemprop='name'>sacralpanda</span>
</a>
</h2>
</div>
<div class='descriptionwrapper'>
<p class='description'><span>
</span></p>
</div>
</div>
</div></div>
</div>
<div class='header-right no-items section' id='header-right'>
</div>
<div class='clear'></div>
</div>
</div>
<div class='clear'></div>
<div class='container'>
<nav class='main-nav' itemscope='itemscope' itemtype='http://schema.org/SiteNavigationElement' role='navigation'>
<div class='resp-desk'><a href='#' id='duled'><i class='fa fa-reorder'></i> Categories</a></div>
<form action='/search' id='peekar'>
<input name='q' onblur='if (this.value == "") {this.value = "Search this site...";}' onfocus='if (this.value == "Search this site...") {this.value = "";}' type='text' value='Search this site...'/>
<button title='Search' type='submit'><span class='fa fa-search'></span></button>
</form>
<ul class='menu'>
<!-- Customize Navigation Menu Here -->
<li class='home'><a href='http://www.sacralpanda.com/'>Home</a></li>
<li><a class='with-ul' href='#' itemprop='url'><span itemprop='name'>Spiritual</span></a>
<ul class='sub-menu'>
<span class='boped'>
<li><a href='http://www.sacralpanda.com/search/label/awakening'>Spiritual Awakening</a></li>
<li><a href='http://www.sacralpanda.com/search/label/twinflames'>Twinflames</a></li>
<li><a href='http://www.sacralpanda.com/search/label/lightworker'>Lightworker</a></li>
<li><a href='http://www.sacralpanda.com/search/label/empath'>Empath</a></li>
<li><a href='http://www.sacralpanda.com/search/label/earth_angels'>Earth Angels</a></li>
<li><a href='http://www.sacralpanda.com/search/label/personal_development'>Personal Development</a></li>
<li><a href='http://www.sacralpanda.com/search/label/spiritual_growth'>Spiritual Growth</a></li>
<li><a href='http://www.sacralpanda.com/search/label/indigos'>Indigos</a></li>
<li><a href='http://www.sacralpanda.com/search/label/crystals'>Crystals</a></li>
<li><a href='http://www.sacralpanda.com/search/label/rainbows'>Rainbows</a></li>
<li><a href='http://www.sacralpanda.com/search/label/howto'>How To</a></li>
<li><a href='http://www.sacralpanda.com/search/label/shamanism'>Shamanism</a></li>
<li><a href='http://www.sacralpanda.com/search/label/relationships'>Relationships</a></li>
<li><a href='http://www.sacralpanda.com/search/label/healing'>Healing</a></li>
<li><a href='http://www.sacralpanda.com/search/label/medium'>Medium</a></li>
<li><a href='http://www.sacralpanda.com/search/label/psychic'>Psychic</a></li>
<li><a href='http://www.sacralpanda.com/search/label/dream_analysis'>Dream Analysis</a></li>
<li><a href='http://www.sacralpanda.com/search/label/reincarnation'>Reincarnation</a></li>
<li><a href='http://www.sacralpanda.com/search/label/karma'>Karma</a></li>
</span>
<span class='btf-thumb'>
<span id='tempic'></span>
<script type='text/javascript'>
Navigar({
idcontaint:"#tempic",
MaxPost:3,
ImageSize:280,
FirstImageSize:280,
tagName:"spiritual"
});
</script>
</span>
</ul>
</li>
<li><a class='with-ul' href='#' itemprop='url'><span itemprop='name'>Mega Posts</span></a>
<ul class='sub-menu'>
<span class='boped'>
<li><a href='#'>Science Fiction</a></li>
<li><a href='http://www.sacralpanda.com/search/label/mythology'>Mythology</a></li>
<li><a href='http://www.sacralpanda.com/search/label/religion'>Religion</a></li>
<li><a href='#'>History</a></li>
<li><a href='#'>Life Style</a></li>
<li><a href='http://www.sacralpanda.com/search/label/Linux'>Linux</a></li>
<li><a href='http://www.sacralpanda.com/search/label/mercedes_benz'>Mercedes Benz</a></li>
<li><a href='http://www.sacralpanda.com/search/label/fitness'>Fitness</a></li>
</span>
<span class='btf-thumb'>
<span id='fubic'></span>
<script type='text/javascript'>
Navigar({
idcontaint:"#fubic",
MaxPost:3,
ImageSize:280,
FirstImageSize:280,
tagName:"Photography"
});
</script>
</span>
</ul>
</li>
<li><a class='with-ul' href='#' itemprop='url'><span itemprop='name'>Conspiracy</span></a>
<ul class='sub-menu'>
<span class='boped'>
<li><a href='#'>Science</a></li>
<li><a href='#'>Religion</a></li>
<li><a href='#'>Illuminati</a></li>
<li><a href='#'>Aliens</a></li>
<li><a href='#'>UFOs</a></li>
<li><a href='#'>New World Order</a></li>
<li><a href='#'>Extraterrestials</a></li>
<li><a href='#'>Reptillians</a></li>
<li><a href='#'>Alien Agenda</a></li>
<li><a href='#'>Military Abductions</a></li>
</span>
<span class='btf-thumb'>
<span id='crozen'></span>
<script type='text/javascript'>
Navigar({
idcontaint:"#crozen",
MaxPost:3,
ImageSize:280,
FirstImageSize:280,
tagName:"conspiracy"
});
</script>
</span>
</ul>
</li>
<li><a class='with-ul' href='#' itemprop='url'><span itemprop='name'>Science</span></a>
<ul class='sub-menu'>
<span class='boped'>
<li><a href='#'>Artificial Intelligence</a></li>
<li><a href='#'>Maths</a></li>
<li><a href='#'>Physics</a></li>
<li><a href='#'>Chemistry</a></li>
<li><a href='#'>Biology</a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'>Big Bang</a></li>
</span>
<span class='btf-thumb'>
<span id='tempic'></span>
<script type='text/javascript'>
Navigar({
idcontaint:"#tempic",
MaxPost:3,
ImageSize:280,
FirstImageSize:280,
tagName:"Science"
});
</script>
</span>
</ul>
</li>
<li><a class='with-ul' href='#' itemprop='url'><span itemprop='name'>Culture</span></a>
<ul class='sub-menu'>
<span class='boped'>
<li><a href='#'>Goth</a></li>
<li><a href='#'>Nerd</a></li>
<li><a href='#'>Hip Hop</a></li>
<li><a href='#'>Hipster</a></li>
<li><a href='#'>Hippie</a></li>
<li><a href='#'>Cyborg</a></li>
<li><a href='#'>Cyberpunk</a></li>
<li><a href='#'>Geek</a></li>
<li><a href='#'>Hacker</a></li>
<li><a href='#'>Doer</a></li>
<li><a href='#'>Book Nerd</a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
</span>
<span class='btf-thumb'>
<span id='tempic'></span>
<script type='text/javascript'>
Navigar({
idcontaint:"#tempic",
MaxPost:3,
ImageSize:280,
FirstImageSize:280,
tagName:"Gadgets"
});
</script>
</span>
</ul>
</li>
<li><a class='with-ul' href='#' itemprop='url'><span itemprop='name'>Ancient Civilizations</span></a>
<ul class='sub-menu'>
<span class='boped'>
<li><a href='#'>Atlantis</a></li>
<li><a href='#'>Lemuria</a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
<li><a href='#'></a></li>
</span>
<span class='btf-thumb'>
<span id='tempic'></span>
<script type='text/javascript'>
Navigar({
idcontaint:"#tempic",
MaxPost:3,
ImageSize:280,
FirstImageSize:280,
tagName:"Gadgets"
});
</script>
</span>
</ul>
</li>
<li><a href='http://www.bloggertheme9.com/2016/03/best-mag-blogger-template.html' target='_blank' title='Grab Here'>
<i class='fa fa-download' style='font-size:16px'></i></a></li>
</ul>
</nav>
</div>
<div class='clear'></div>
<div class='outer-wrapper'>
<div class='container'>
<div class='crosscol no-items section' id='crosscol'>
</div><div class='clear'></div>
</div><!--Div Container-->
<div class='container'>
</div><!--Div Container-->
<div class='container'>
<div class='main-wrapper'>
<div class='main-inner-wrap'>
<div class='main section' id='main' name='Main'><div class='widget Blog' data-version='1' id='Blog1'>
<div id='breadcrumbs'>
<ul>
<span itemscope='' itemtype='http://data-vocabulary.org/Breadcrumb'><a href='http://www.sacralpanda.com/' itemprop='url'><span itemprop='title' style='padding-left:8px;'><i class='fa fa-home'></i>
sacralpanda</span></a></span>
<li itemtype='http://data-vocabulary.org/Breadcrumb'><a href='http://www.sacralpanda.com/search/label/coder?&amp;max-results=6' itemprop='url'><span itemprop='title'>
coder</span></a></li><li itemtype='http://data-vocabulary.org/Breadcrumb'><a href='http://www.sacralpanda.com/search/label/coding?&amp;max-results=6' itemprop='url'><span itemprop='title'>
coding</span></a></li><li itemtype='http://data-vocabulary.org/Breadcrumb'><a href='http://www.sacralpanda.com/search/label/opensource?&amp;max-results=6' itemprop='url'><span itemprop='title'>
opensource</span></a></li><li itemtype='http://data-vocabulary.org/Breadcrumb'><a href='http://www.sacralpanda.com/search/label/programmig?&amp;max-results=6' itemprop='url'><span itemprop='title'>
programmig</span></a></li><li itemtype='http://data-vocabulary.org/Breadcrumb'><a href='http://www.sacralpanda.com/search/label/python?&amp;max-results=6' itemprop='url'><span itemprop='title'>
python</span></a></li><li itemtype='http://data-vocabulary.org/Breadcrumb'><a href='http://www.sacralpanda.com/search/label/tech?&amp;max-results=6' itemprop='url'><span itemprop='title'>
tech</span></a></li>
</ul>
</div>
<div class='blog-posts hfeed'>

          <div class="date-outer">
        
<h2 class='date-header'><span>Monday, August 14, 2017</span></h2>

          <div class="date-posts">
        
<div class='post-outer'>
<div class='post hentry uncustomized-post-template' itemprop='blogPost' itemtype='http://schema.org/BlogPosting'>
<meta content='https://4.bp.blogspot.com/--kK4JVIv8wI/Vx5bqCL97OI/AAAAAAAABk4/5cwFvsWA77MTygYwmjXyllZbyRdIvtQugCLcB/s640/coding-640x356.jpg' itemprop='image_url'/>
<meta content='3019166093343777824' itemprop='blogId'/>
<meta content='7647189486764722753' itemprop='postId'/>
<a name='7647189486764722753'></a>
<h1 class='post-title entry-title' itemprop='name'>
How to become a python coder, first part
</h1>
<div class='nread'>
<div class='title-secondary'>
<span class='fa fa-pencil-square-o'></span>
<span class='post-author vcard'>
</span>

&nbsp;
<i class='fa fa-calendar-o'></i>
<span class='post-timestamp'>
<meta content='http://www.sacralpanda.com/2017/08/how-to-become-python-coder-first-part.html' itemprop='url'/>
<a class='timestamp-link' href='http://www.sacralpanda.com/2017/08/how-to-become-python-coder-first-part.html' rel='bookmark' title='permanent link'><span class='published' itemprop='datePublished' title='2017-08-14T07:02:00-07:00'>August 14, 2017</span></a>
</span>
<span class='item-control blog-admin pid-787622205'>
<a href='https://www.blogger.com/post-edit.g?blogID=3019166093343777824&postID=7647189486764722753&from=pencil' title='Edit Post'>
<img alt='' class='icon-action' height='18' src='//img2.blogblog.com/img/icon18_edit_allbkg.gif' width='18'/>
</a>
</span>
</div>
<div class='feet-icons'>
<a class='facebook-ico' href='https://www.blogger.com/share-post.g?blogID=3019166093343777824&postID=7647189486764722753&target=facebook' onclick='window.open(this.href, "_blank", "height=430,width=640"); return false;' target='_blank' title='Share to Facebook'><i class='fa fa-facebook'></i></a>
<a class='twitter-ico' href='https://www.blogger.com/share-post.g?blogID=3019166093343777824&postID=7647189486764722753&target=twitter' target='_blank' title='Share to Twitter'><i class='fa fa-twitter'></i></a>
<a class='plus-ico' href='https://plus.google.com/share?url=http://www.sacralpanda.com/2017/08/how-to-become-python-coder-first-part.html' target='_blank' title='Share on Google+'><i class='fa fa-google-plus'></i></a>
<a class='email-ico' href='https://www.blogger.com/share-post.g?blogID=3019166093343777824&postID=7647189486764722753&target=email' target='_blank' title='Email This'><i class='fa fa-envelope-o'></i></a>
<a class='pinterest-ico' href='https://www.blogger.com/share-post.g?blogID=3019166093343777824&postID=7647189486764722753&target=pinterest' target='_blank' title='Share to Pinterest'><i class='fa fa-pinterest'></i></a>
</div>
</div>
<div class='post-header'>
<div class='post-header-line-1'></div>
</div>
<div class='post-body entry-content' id='post-body-7647189486764722753' itemprop='description articleBody'>
<p><div class="separator" style="clear: both; text-align: justify;">
<a href="https://4.bp.blogspot.com/--kK4JVIv8wI/Vx5bqCL97OI/AAAAAAAABk4/5cwFvsWA77MTygYwmjXyllZbyRdIvtQugCLcB/s1600/coding-640x356.jpg" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" height="355" src="https://4.bp.blogspot.com/--kK4JVIv8wI/Vx5bqCL97OI/AAAAAAAABk4/5cwFvsWA77MTygYwmjXyllZbyRdIvtQugCLcB/s640/coding-640x356.jpg" width="640" /></a></div>
<div style="text-align: justify;">
<br /></div>
<div style="text-align: justify;">
<br /></div>
<h2 style="text-align: justify;">
What is python&nbsp;</h2>
<div style="text-align: justify;">
Python is a high level computer programming language easy to learn and put in use by anyone who is passionate about coding. The first time I started reading some python code it felt like i was reading myself, I mean my thoughts converted to code.</div>
<div style="text-align: justify;">
<br /></div>
<div style="text-align: justify;">
Heavily used by <b>Google</b> and <b>Youtube</b>, python is becoming very popular among computer programmers all over the world espcially in the startup world as it features rapid development, which makes it one of the number one technologies when it comes to prototyping. &nbsp;</div>
<h2 style="text-align: justify;">
Why learn python</h2>
<div style="text-align: justify;">
Many of you may ask why learn python and not java or another programming language. This is the right question to ask for a starter in the coding world and I will list some arguments below why you should start learning python.</div>
<div style="text-align: justify;">
<br /></div>
<div style="text-align: justify;">
It will take you probably two weeks to learn all the python syntax needed to build real world applications. Or just a few days if you are a passionate reader about these kind of topics.</div>
<div style="text-align: justify;">
<br /></div>
<div style="text-align: justify;">
The fact python is easy to read makes it easy for you as a developer to maintain the code of your project. As the project grows in terms of code you don't want to come back after your holidays and when looking at the code you have written not getting shit on what it does.</div>
<div style="text-align: justify;">
<br /></div>
<div style="text-align: justify;">
I have had the chance to talk to a python developer who did perl programming for a living back in the days and he told me it is real hard to maintain the code of his old projects. Not hard, but struggle!</div>
<div style="text-align: justify;">
<br /></div>
<div style="text-align: justify;">
Python is fully <b>Open Source</b> which means that you can look at its implementation code and understand stuff from a lower level perspective.</div>
<div style="text-align: justify;">
<br /></div>
<div style="text-align: justify;">
You can code python on almost any platform. Telling from my experience, I have been able to run my python scrips in both Windows and Linux operating systems except for Mac, because it is such an expensive toy for me, but for sure you can code python on Mac too.</div>
<div style="text-align: justify;">
<br /></div>
<div style="text-align: justify;">
Python is not just a programming language. It has a big community behind who is very welcoming and it makes you feel like <b>Home</b>. I am very happy to have met so many python developers in Firenze Italy back in 2013. I felt real love in there.</div>
<h3 style="text-align: justify;">
Some technical knowledge on python</h3>
<div style="text-align: justify;">
You can notice a python file by the .py extension. Every file that ends with this extension is classified as a python module. For example the following is a python module.</div>
<blockquote class="tr_bq" style="text-align: justify;">
pythongeek.py</blockquote>
<div style="text-align: justify;">
The module serves as a container for the python code of our app and we can use the code of a module in other modules by importing it with the import statement like shown below, but do not try to understand this thing right now as this is just an introduction. I am sure some things may not make sense to you right now and that's alright.</div>
<blockquote class="tr_bq" style="text-align: justify;">
import pythongeek # imports the pythongeek module</blockquote>
<div style="text-align: justify;">
Since python is an intepreted language you will need the official python intepreter to run python code on your machine. In most linux distributions such as Ubuntu it comes installed by default, but in Windows you have to install it yourself.<br />
<script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- post -->
<br />
<ins class="adsbygoogle" data-ad-client="ca-pub-7300728982462487" data-ad-slot="3001220721" style="display: inline-block; height: 280px; width: 336px;"></ins><script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>

<br />
<h2>
Install python on windows</h2>
Installing python on windows is just a matter of clicks, but configuring it to run from the command prompt needs some configuration.<br />
<br />
<div class="separator" style="clear: both; text-align: center;">
</div>
By running python from the command prompt I mean the following.<br />
<br />
<div class="separator" style="clear: both; text-align: justify;">
<a href="https://3.bp.blogspot.com/-4vcYxg6mIgU/Vx-LgdzEnXI/AAAAAAAABlM/1FlbIvNDb7AtX4ZVsz4thtPn2Pa0LUjZgCKgB/s1600/howtobecomeapythoncoder1.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" height="379" src="https://3.bp.blogspot.com/-4vcYxg6mIgU/Vx-LgdzEnXI/AAAAAAAABlM/1FlbIvNDb7AtX4ZVsz4thtPn2Pa0LUjZgCKgB/s640/howtobecomeapythoncoder1.JPG" width="640" /></a></div>
<br />
The first thing we need to do is to find out our system type so we know what kind of python installer to download.<br />
<br />
To find out your system type go to <b>Start</b>, right click on<b> Computer</b> and go to <b>Properties</b>; the following will come up.<br />
<br />
<br />
<div class="separator" style="clear: both; text-align: justify;">
<a href="https://1.bp.blogspot.com/-1SMVhubl1Tc/Vx-OBVcnzzI/AAAAAAAABlY/5wTQcJ5vwPAvrTdSZBKUSCP8AQ2R9aZtQCLcB/s1600/howtobecomeapythoncoder2.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" height="512" src="https://1.bp.blogspot.com/-1SMVhubl1Tc/Vx-OBVcnzzI/AAAAAAAABlY/5wTQcJ5vwPAvrTdSZBKUSCP8AQ2R9aZtQCLcB/s640/howtobecomeapythoncoder2.JPG" width="640" /></a></div>
<br />
As you can see from the above screenshot I have a 64 bit machine. I need to download the python installer for 64 bit system type.<br />
<br />
Now go to the python <a href="http://www.python.org/">official website</a> and go to Downloads. Under Downloads click on the Windows category.<br />
<br />
Depending on the system type you have, you need to download the right version for it. In the following screenshot everything is self explanatory so take a look at it and click on the python installer for your type.<br />
<br />
<b>Note</b>: The version of python we need is 2.7.11<br />
<br />
<br />
<div class="separator" style="clear: both; text-align: justify;">
<a href="https://3.bp.blogspot.com/-_VRSpQNlrHE/Vx-RFwfRFfI/AAAAAAAABlk/2MoRcQt1GzAqW8eEI5dUXKAU65m3wJ1fACLcB/s1600/howtobecomeapythoncoder3.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" height="422" src="https://3.bp.blogspot.com/-_VRSpQNlrHE/Vx-RFwfRFfI/AAAAAAAABlk/2MoRcQt1GzAqW8eEI5dUXKAU65m3wJ1fACLcB/s640/howtobecomeapythoncoder3.JPG" width="640" /></a></div>
<br />
Download the right version of python for you and move it on Desktop like shown below.<br />
<br />
<div class="separator" style="clear: both; text-align: justify;">
<a href="https://2.bp.blogspot.com/-qI0pZOSi3qk/Vx-TtX1vsUI/AAAAAAAABlw/5eNPponiXOE8INo59592_xXHs3a1iPKBACKgB/s1600/howtobecomeapythoncoder4.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" height="472" src="https://2.bp.blogspot.com/-qI0pZOSi3qk/Vx-TtX1vsUI/AAAAAAAABlw/5eNPponiXOE8INo59592_xXHs3a1iPKBACKgB/s640/howtobecomeapythoncoder4.JPG" width="640" /></a></div>
<br />
Then do a right click on the python installer you just moved to Desktop and click on Install. The installation of python will start.<br />
<br />
The following box will show up.<br />
<br />
<br />
<div class="separator" style="clear: both; text-align: justify;">
<a href="https://2.bp.blogspot.com/-NR-atXI2IkQ/Vx-Wu9MtLeI/AAAAAAAABl4/kuV2Fq4NM-QP1dZ1HltQQYKvA2MkUNMEgCLcB/s1600/howtobecomeapythoncoder5.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" height="550" src="https://2.bp.blogspot.com/-NR-atXI2IkQ/Vx-Wu9MtLeI/AAAAAAAABl4/kuV2Fq4NM-QP1dZ1HltQQYKvA2MkUNMEgCLcB/s640/howtobecomeapythoncoder5.JPG" width="640" /></a></div>
<br />
<br />
If you don't want to make python available to other users then just select the second option and click Next.<br />
<br />
I prefer to leave this as default.<br />
<br />
The next box will ask you about the path where you want python to be installed. Please leave this as default as you are new to this stuff.<br />
<br />
<br />
<div class="separator" style="clear: both; text-align: justify;">
<a href="https://3.bp.blogspot.com/-rdsmeag2SbI/Vx-XmXLJW5I/AAAAAAAABmA/igab--i2a2gJUrS6xktInXz5VVolWqpPgCKgB/s1600/howtobecomeapythoncoder6.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" height="552" src="https://3.bp.blogspot.com/-rdsmeag2SbI/Vx-XmXLJW5I/AAAAAAAABmA/igab--i2a2gJUrS6xktInXz5VVolWqpPgCKgB/s640/howtobecomeapythoncoder6.JPG" width="640" /></a></div>
<br />
<br />
<div class="separator" style="clear: both; text-align: center;">
</div>
The C:\Python27\ is the path where our python installation is going to be placed. We will need this path for some configuration so make sure to save it in a notepad file.<br />
<br />
<blockquote class="tr_bq">
C:\Python27\&nbsp;</blockquote>
Then the following will show up.<br />
<br />
<div class="separator" style="clear: both; text-align: justify;">
<a href="https://2.bp.blogspot.com/-4IxxvIckytU/Vx-Y6flpw0I/AAAAAAAABmM/TsZe7XnsUdwB-UNPhFTy1lf47hh_snYHwCKgB/s1600/howtobecomeapythoncoder7.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" height="550" src="https://2.bp.blogspot.com/-4IxxvIckytU/Vx-Y6flpw0I/AAAAAAAABmM/TsZe7XnsUdwB-UNPhFTy1lf47hh_snYHwCKgB/s640/howtobecomeapythoncoder7.JPG" width="640" /></a></div>
<br />
<br />
Click Next.<br />
<br />
<br />
<div class="separator" style="clear: both; text-align: center;">
</div>
The installation will start.<br />
<br />
<br />
<div class="separator" style="clear: both; text-align: justify;">
<a href="https://3.bp.blogspot.com/-4WAj2EC3E7o/Vx-aS5LmlXI/AAAAAAAABmY/kiosqOXvejARUFr1WqwNI8mqre3dZZLoQCLcB/s1600/howtobecomeapythoncoder8.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" height="552" src="https://3.bp.blogspot.com/-4WAj2EC3E7o/Vx-aS5LmlXI/AAAAAAAABmY/kiosqOXvejARUFr1WqwNI8mqre3dZZLoQCLcB/s640/howtobecomeapythoncoder8.JPG" width="640" /></a></div>
<br />
<div class="separator" style="clear: both; text-align: center;">
</div>
<br />
<br />
When you are close to finish, just click finish.<br />
<br />
<br />
<div class="separator" style="clear: both; text-align: justify;">
<a href="https://4.bp.blogspot.com/-JqMjWl_bhj4/Vx-aengS-mI/AAAAAAAABmc/zhTMmL2Tpx4oM4dqm_Zo56d-TmkxM7CiACKgB/s1600/howtobecomeapythoncoder9.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" height="550" src="https://4.bp.blogspot.com/-JqMjWl_bhj4/Vx-aengS-mI/AAAAAAAABmc/zhTMmL2Tpx4oM4dqm_Zo56d-TmkxM7CiACKgB/s640/howtobecomeapythoncoder9.JPG" width="640" /></a></div>
<br />
To be able to run python from the command prompt, it is needed that we configure the <b>PATH </b>environment variable.<br />
<br />
1. Go to <b>Start, Computer, Properties</b>.<br />
<br />
2. Click on Advanced system settings.<br />
<br />
<div class="separator" style="clear: both; text-align: center;">
<a href="https://2.bp.blogspot.com/-prwUAq_Izng/WZGpXyYEcII/AAAAAAAAC-c/tlIx4YrYcTYYZPfxeqBSo-tH52c4mcuMwCLcBGAs/s1600/w1.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" data-original-height="544" data-original-width="860" height="404" src="https://2.bp.blogspot.com/-prwUAq_Izng/WZGpXyYEcII/AAAAAAAAC-c/tlIx4YrYcTYYZPfxeqBSo-tH52c4mcuMwCLcBGAs/s640/w1.JPG" width="640" /></a></div>
<br />
3. The following will come up.<br />
<br />
<div class="separator" style="clear: both; text-align: center;">
<a href="https://4.bp.blogspot.com/-q6MAs3AEj54/WZGqXIXOAAI/AAAAAAAAC-k/o_nLGpLJ-IglTKvq0aPIRUT7SL5Sco1IwCLcBGAs/s1600/w2.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" data-original-height="472" data-original-width="426" height="640" src="https://4.bp.blogspot.com/-q6MAs3AEj54/WZGqXIXOAAI/AAAAAAAAC-k/o_nLGpLJ-IglTKvq0aPIRUT7SL5Sco1IwCLcBGAs/s640/w2.JPG" width="576" /></a></div>
<br />
4. Click on Environment Variables.<br />
<br />
<div class="separator" style="clear: both; text-align: center;">
<a href="https://2.bp.blogspot.com/-lG_gWlxWoVg/WZGqtiNYZ1I/AAAAAAAAC-o/Dxkv3nASmH45KRzSlU1IkNltHB_69bLzgCLcBGAs/s1600/w3.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" data-original-height="471" data-original-width="429" height="640" src="https://2.bp.blogspot.com/-lG_gWlxWoVg/WZGqtiNYZ1I/AAAAAAAAC-o/Dxkv3nASmH45KRzSlU1IkNltHB_69bLzgCLcBGAs/s640/w3.JPG" width="582" /></a></div>
<br />
5. Under &nbsp;System variables, look for <b>PATH</b> and double click on it.<br />
<br />
<div class="separator" style="clear: both; text-align: center;">
<a href="https://4.bp.blogspot.com/-E7271P-UvT4/WZGr4RJEDQI/AAAAAAAAC-w/WtMPHgRgfioVpebj7wYn09um-D_ypbAogCLcBGAs/s1600/w4.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" data-original-height="438" data-original-width="390" height="640" src="https://4.bp.blogspot.com/-E7271P-UvT4/WZGr4RJEDQI/AAAAAAAAC-w/WtMPHgRgfioVpebj7wYn09um-D_ypbAogCLcBGAs/s640/w4.JPG" width="568" /></a></div>
<br />
6. The following will come up.<br />
<br />
<div class="separator" style="clear: both; text-align: center;">
<a href="https://2.bp.blogspot.com/-GgmhyL5-7nI/WZGsl_wYkmI/AAAAAAAAC-4/4qk4AVXYJoc1goFb_3esnv1qLB3S229dACLcBGAs/s1600/w5.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" data-original-height="152" data-original-width="356" height="272" src="https://2.bp.blogspot.com/-GgmhyL5-7nI/WZGsl_wYkmI/AAAAAAAAC-4/4qk4AVXYJoc1goFb_3esnv1qLB3S229dACLcBGAs/s640/w5.JPG" width="640" /></a></div>
<br />
7. At the end of the Variable value copy and paste the following and click OK.<br />
<blockquote class="tr_bq">
;C:\Python27</blockquote>
8. You are done.<br />
<br />
9. Open the command prompt by going to Start and on the search bar type <b>cmd</b>. Run it and check if it is possible to execute python directly from it.<br />
<br />
<div class="separator" style="clear: both; text-align: center;">
<a href="https://3.bp.blogspot.com/-eivDRIDlHj0/WZGteIiy-SI/AAAAAAAAC_A/ANLr3s2h4lASn6YDidSYzBxqhnG3hXD2wCLcBGAs/s1600/w6.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" data-original-height="341" data-original-width="673" height="324" src="https://3.bp.blogspot.com/-eivDRIDlHj0/WZGteIiy-SI/AAAAAAAAC_A/ANLr3s2h4lASn6YDidSYzBxqhnG3hXD2wCLcBGAs/s640/w6.JPG" width="640" /></a></div>
<br />
<br />
I also uploaded the following video on youtube that teaches you step by step how to install python on a windows 7 machine.<br />
<br />
<div class="separator" style="clear: both; text-align: justify;">
<iframe allowfullscreen="" class="YOUTUBE-iframe-video" data-thumbnail-src="https://i.ytimg.com/vi/Dl_5eMYVEj8/0.jpg" frameborder="0" height="266" src="https://www.youtube.com/embed/Dl_5eMYVEj8?feature=player_embedded" width="320"></iframe></div>
<br />
<h2>
Some python coding basics</h2>
Now that you have python available on your machine, it is time to build some basic coding skills to build the foundations for further development.<br />
<br />
To open the python shell on windows just go to Start and in the search box type python. Then click on IDLE (Python GUI). The following python <b>graphical shell</b> will come up.<br />
<br />
<br />
<div class="separator" style="clear: both; text-align: justify;">
<a href="https://3.bp.blogspot.com/-ej5LOdfYBC4/Vx_iFILKasI/AAAAAAAABmw/Cj-cgtgDLjMqwUlDta4ZZfwii-AEkcyRgCKgB/s1600/howtobecomeapythoncoder10.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" height="640" src="https://3.bp.blogspot.com/-ej5LOdfYBC4/Vx_iFILKasI/AAAAAAAABmw/Cj-cgtgDLjMqwUlDta4ZZfwii-AEkcyRgCKgB/s640/howtobecomeapythoncoder10.JPG" width="612" /></a></div>
<br />
<br />
This is the shell where we are going to practice python.<br />
<br />
The first thing you need to learn in python is how to declare a variable. You can declare a variable in python like shown below.<br />
<br />
<blockquote class="tr_bq">
a = 5</blockquote>
<br />
Where a is the name of the variable and 5 is the value this variable is linked to.<br />
<br />
<br />
<div class="separator" style="clear: both; text-align: center;">
</div>
<div class="separator" style="clear: both; text-align: justify;">
<a href="https://1.bp.blogspot.com/-gSzkvX_OoqY/Vx_kWyZcaHI/AAAAAAAABm8/SJc2EewPhfQtJt27C0eikD1eG351QEMYACLcB/s1600/howtobecomeapythoncoder11.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" height="640" src="https://1.bp.blogspot.com/-gSzkvX_OoqY/Vx_kWyZcaHI/AAAAAAAABm8/SJc2EewPhfQtJt27C0eikD1eG351QEMYACLcB/s640/howtobecomeapythoncoder11.JPG" width="610" /></a></div>
<br />
<br />
To get the value of the variable you type the name of it and hit Return (Enter) on your keyboard.<br />
<br />
<blockquote class="tr_bq">
a</blockquote>
<div class="separator" style="clear: both; text-align: justify;">
<a href="https://4.bp.blogspot.com/-sPq_6zi6GSc/Vx_k9z7OsYI/AAAAAAAABnA/WEZ8qj12iPozk7t4oy5IwaEwAYhT54_3QCLcB/s1600/howtobecomeapythoncoder12.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" height="640" src="https://4.bp.blogspot.com/-sPq_6zi6GSc/Vx_k9z7OsYI/AAAAAAAABnA/WEZ8qj12iPozk7t4oy5IwaEwAYhT54_3QCLcB/s640/howtobecomeapythoncoder12.JPG" width="606" /></a></div>
<br />
You can also do some maths.<br />
<br />
<blockquote class="tr_bq">
a + 1 # hit Enter</blockquote>
<br />
<div class="separator" style="clear: both; text-align: justify;">
<a href="https://1.bp.blogspot.com/-3GJh0--LYQI/Vx_mgzK2caI/AAAAAAAABnQ/23KKeHUYsOYAcGS_qN8PXmfsI7EOVJbOgCLcB/s1600/howtobecomeapythoncoder13.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" height="640" src="https://1.bp.blogspot.com/-3GJh0--LYQI/Vx_mgzK2caI/AAAAAAAABnQ/23KKeHUYsOYAcGS_qN8PXmfsI7EOVJbOgCLcB/s640/howtobecomeapythoncoder13.JPG" width="606" /></a></div>
<br />
Let's get more pythonic. There are special builtin datatypes in python such as the following:<br />
<br />
<ul>
<li>Lists</li>
<li>Tuples</li>
<li>Dictionaries</li>
</ul>
<br />
There are many others, but for the purpose of this tutorial we will take a look at the ones listed above.<br />
<br />
Let's take a look at lists. For example the following is a list assigned to variable l.<br />
<blockquote class="tr_bq">
l = ['python', 'geek', 'google', 'youtube']</blockquote>
<br />
<div class="separator" style="clear: both; text-align: justify;">
<a href="https://2.bp.blogspot.com/-Ga48LfChMDo/Vx_uxjaV2bI/AAAAAAAABng/EHkKRO-ZwtUA8QBBmgIgOR6BclcqYX36gCLcB/s1600/howtobecomeapythoncoder14.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" height="640" src="https://2.bp.blogspot.com/-Ga48LfChMDo/Vx_uxjaV2bI/AAAAAAAABng/EHkKRO-ZwtUA8QBBmgIgOR6BclcqYX36gCLcB/s640/howtobecomeapythoncoder14.JPG" width="606" /></a></div>
<br />
<br />
<br />
Lists elements can be accessed and used in a program. For example to access the first element of the list you use the following syntax.<br />
<blockquote class="tr_bq">
l[0] # where l is the list and 0 is the index of the first element</blockquote>
<br />
<br />
<div class="separator" style="clear: both; text-align: justify;">
<a href="https://1.bp.blogspot.com/-hXyks4ZBT10/Vx_u3i46IyI/AAAAAAAABnk/zKm0r9AamRgkiZmVDJ3YvyAYFDYc49QdgCLcB/s1600/howtobecomeapythoncoder15.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" height="640" src="https://1.bp.blogspot.com/-hXyks4ZBT10/Vx_u3i46IyI/AAAAAAAABnk/zKm0r9AamRgkiZmVDJ3YvyAYFDYc49QdgCLcB/s640/howtobecomeapythoncoder15.JPG" width="602" /></a></div>
<br />
<br />
So to access the second element you do the following.<br />
<blockquote class="tr_bq">
l[1]</blockquote>
<br />
<div class="separator" style="clear: both; text-align: justify;">
<a href="https://4.bp.blogspot.com/-nW5mj7IjIHU/Vx_u8e_g62I/AAAAAAAABno/f-whH7CFEHUL3SrbyS8D91aTeM949LywwCLcB/s1600/howtobecomeapythoncoder16.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" height="640" src="https://4.bp.blogspot.com/-nW5mj7IjIHU/Vx_u8e_g62I/AAAAAAAABno/f-whH7CFEHUL3SrbyS8D91aTeM949LywwCLcB/s640/howtobecomeapythoncoder16.JPG" width="608" /></a></div>
<br />
A list can be updated. For example you can change the first element in our list by doing the following.<br />
<br />
<blockquote class="tr_bq">
l[0] = 'ruby'</blockquote>
<br />
As you can see, when printing the new list the first element is updated.<br />
<br />
<blockquote class="tr_bq">
l</blockquote>
<br />
<div class="separator" style="clear: both; text-align: justify;">
<a href="https://1.bp.blogspot.com/-92nDTQchAq0/Vx_3Th2-1fI/AAAAAAAABn8/XIZmfTb3RBU7swS0n1RYKHkhmf_HBW4HwCLcB/s1600/howtobecomeapythoncoder17.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" height="640" src="https://1.bp.blogspot.com/-92nDTQchAq0/Vx_3Th2-1fI/AAAAAAAABn8/XIZmfTb3RBU7swS0n1RYKHkhmf_HBW4HwCLcB/s640/howtobecomeapythoncoder17.JPG" width="608" /></a></div>
<br />
<br />
We will cover lists in more depth in specific tutorials. Now it is time to learn about tuples.<br />
<br />
You can define a tuple like shown below.<br />
<blockquote class="tr_bq">
t = ('python', 'geek', 'internet', 'skype')</blockquote>
<br />
<div class="separator" style="clear: both; text-align: justify;">
<a href="https://3.bp.blogspot.com/-QiOEOLrpwvU/Vx_7_LG9veI/AAAAAAAABoI/hWuB9qiR9xQPSo49CdYDjhfTTq2oBAZsACLcB/s1600/howtobecomeapythoncoder18.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" height="640" src="https://3.bp.blogspot.com/-QiOEOLrpwvU/Vx_7_LG9veI/AAAAAAAABoI/hWuB9qiR9xQPSo49CdYDjhfTTq2oBAZsACLcB/s640/howtobecomeapythoncoder18.JPG" width="608" /></a></div>
<br />
<br />
<br />
The same as in lists you can do indexing in tuples too.<br />
<br />
For example to get the first element of the above tuple you do the following.<br />
<blockquote class="tr_bq">
t[0]</blockquote>
<br />
<div class="separator" style="clear: both; text-align: justify;">
<a href="https://1.bp.blogspot.com/-KPtgS0i7B-4/Vx_8HFOVsTI/AAAAAAAABoM/k4xmZB-PKpkU9WmNX739zT9zJPBYqYqRQCLcB/s1600/howtobecomeapythoncoder19.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" height="640" src="https://1.bp.blogspot.com/-KPtgS0i7B-4/Vx_8HFOVsTI/AAAAAAAABoM/k4xmZB-PKpkU9WmNX739zT9zJPBYqYqRQCLcB/s640/howtobecomeapythoncoder19.JPG" width="606" /></a></div>
<br />
<br />
<br />
So tuples are like lists? Not really!<br />
<br />
Try to update the first element of the tuple we have and see what happens.<br />
<blockquote class="tr_bq">
t[0] = 'ruby'</blockquote>
<br />
<div class="separator" style="clear: both; text-align: justify;">
<a href="https://3.bp.blogspot.com/-ecug55so2kM/Vx_8L2zPaHI/AAAAAAAABoQ/QvL3jEkSFCU5aHPSoN3BDvAKfOWMwp_EQCLcB/s1600/howtobecomeapythoncoder20.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" height="640" src="https://3.bp.blogspot.com/-ecug55so2kM/Vx_8L2zPaHI/AAAAAAAABoQ/QvL3jEkSFCU5aHPSoN3BDvAKfOWMwp_EQCLcB/s640/howtobecomeapythoncoder20.JPG" width="606" /></a></div>
<br />
<div class="separator" style="clear: both; text-align: center;">
</div>
Enough about tuples.<br />
<br />
Let's move to dictionaries. For example the following is a python dictionary.<br />
<blockquote class="tr_bq">
d = {'name': 'pythongeek', 'occupation': 'maths', 'age':13}</blockquote>
<br />
<div class="separator" style="clear: both; text-align: justify;">
<a href="https://2.bp.blogspot.com/-O5dgx228oBs/VyAAU99_ASI/AAAAAAAABog/4W43Myjp6lsmMto5UvkVQhmylDLw93_PgCLcB/s1600/howtobecomeapythoncoder21.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" height="640" src="https://2.bp.blogspot.com/-O5dgx228oBs/VyAAU99_ASI/AAAAAAAABog/4W43Myjp6lsmMto5UvkVQhmylDLw93_PgCLcB/s640/howtobecomeapythoncoder21.JPG" width="608" /></a></div>
<br />
Each item of the dictionary is composed of two elements: a key and a value. For example the first item of our dictionary is composed of the key 'name' and the value 'pythongeek'.<br />
<br />
Try the following.<br />
<br />
<blockquote class="tr_bq">
d['name']</blockquote>
<br />
<div class="separator" style="clear: both; text-align: center;">
<a href="https://1.bp.blogspot.com/-G7XLRGnxl7M/VyADI77EMAI/AAAAAAAABos/br_zaTj-m8ITYg9HRu15VeX4sayBXcYvgCLcB/s1600/howtobecomeapythoncoder22.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" height="640" src="https://1.bp.blogspot.com/-G7XLRGnxl7M/VyADI77EMAI/AAAAAAAABos/br_zaTj-m8ITYg9HRu15VeX4sayBXcYvgCLcB/s640/howtobecomeapythoncoder22.JPG" width="606" /></a></div>
<br />
<br />
As you can see you access the value of an item by its key, python is very cool. Now if you think we are done, I am sorry but you are completely wrong!<br />
<br />
We have to learn about functions now. As in math, a python function takes an input and returns a value.<br />
<br />
For example the following is a math function.<br />
<blockquote class="tr_bq">
y = f(x)</blockquote>
The value of y depends on the value of x and what kind of function f is. A python function is defined with the def statement followed by the name of the function and a colon like shown below.<br />
<br />
<blockquote class="tr_bq">
def py_function():<br />
&nbsp; &nbsp; print('Python Coder')</blockquote>
<br />
I will explain the above function in details, but for now open a new python graphical shell and type the followings one by one.<br />
<blockquote class="tr_bq">
def py_function():</blockquote>
<div class="separator" style="clear: both; text-align: center;">
<a href="https://3.bp.blogspot.com/-sRaQixurTpM/VyAH99Gl_bI/AAAAAAAABo8/MSlPOc964qMi0LVSnRgHs2xyjIYIyVHBgCLcB/s1600/howtobecomeapythoncoder23.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" height="640" src="https://3.bp.blogspot.com/-sRaQixurTpM/VyAH99Gl_bI/AAAAAAAABo8/MSlPOc964qMi0LVSnRgHs2xyjIYIyVHBgCLcB/s640/howtobecomeapythoncoder23.JPG" width="602" /></a></div>
<br />
<br />
Once you have typed the above, hit Enter on your keyboard and type the rest of the function like shown in the following screenshot.<br />
<br />
<div class="separator" style="clear: both; text-align: center;">
<a href="https://3.bp.blogspot.com/-PZu5EIFyJEw/VyAIL0i-fBI/AAAAAAAABpA/gzn9xowdNJY6OjPgzR1VIjlYQt3lkIAxgCLcB/s1600/howtobecomeapythoncoder24.JPG" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" height="640" src="https://3.bp.blogspot.com/-PZu5EIFyJEw/VyAIL0i-fBI/AAAAAAAABpA/gzn9xowdNJY6OjPgzR1VIjlYQt3lkIAxgCLcB/s640/howtobecomeapythoncoder24.JPG" width="604" /></a></div>
<br />
A thing to notice in here is space from left to right that was created when you pressed the Enter button on your keyboard. This space is real important when coding python and it is called indentation. It's purpose is to make the code more readable.<br />
<br />
When you are finished coding the function hit Enter again. Now you are wondering how to use this function.<br />
<br />
To use a function in python just type the name of the function with () and the input it takes inside them.<br />
<br />
Because our function does not take any input we just run it like shown below.<br />
<br />
<blockquote class="tr_bq">
py_function() # calling our function</blockquote>
<h2>
Conclusion</h2>
There is enough information you have been through in this first part. In the second part we will take look at more advanced stuff, but I am sure you will be ready for it if you feel you understand what we covered in here. For anything which you don't understand, feel free to leave a comment in the comments section of this post and I will be more than happy to help you.<br />
<br />
<b>&#169; 2017 Copyright by sacralpanda.com&nbsp;</b><br />
<b>All Rights Reserved.&nbsp;</b></div>
<div style="text-align: justify;">
</div>
<script async='async' src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script>
<ins class='adsbygoogle' data-ad-client='ca-pub-7300728982462487' data-ad-format='auto' data-ad-slot='1335761120' style='display:block'></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
<div style='clear: both;'></div>
</div>
<div class='post-footer'>
<div class='post-footer-line post-footer-line-1'>
<span class='post-backlinks post-comment-link'>
</span>
<span class='post-icons'>
</span>
</div>
<div class='post-footer-line post-footer-line-2'>
<span class='post-labels'>
<span class='fa-stack fa-lg'>
<i class='fa fa-circle fa-stack-2x'></i>
<i class='fa fa-tags fa-stack-1x fa-inverse'></i>
</span>
<a href='http://www.sacralpanda.com/search/label/coder' rel='tag'>coder</a>,
<a href='http://www.sacralpanda.com/search/label/coding' rel='tag'>coding</a>,
<a href='http://www.sacralpanda.com/search/label/opensource' rel='tag'>opensource</a>,
<a href='http://www.sacralpanda.com/search/label/programmig' rel='tag'>programmig</a>,
<a href='http://www.sacralpanda.com/search/label/python' rel='tag'>python</a>,
<a href='http://www.sacralpanda.com/search/label/tech' rel='tag'>tech</a>
</span>
</div>
<div class='post-footer-line post-footer-line-3'>
<div id='related-article'>
<script src='/feeds/posts/default/-/coder?alt=json-in-script&callback=related_results_labels' type='text/javascript'></script>
<script src='/feeds/posts/default/-/coding?alt=json-in-script&callback=related_results_labels' type='text/javascript'></script>
<script src='/feeds/posts/default/-/opensource?alt=json-in-script&callback=related_results_labels' type='text/javascript'></script>
<script src='/feeds/posts/default/-/programmig?alt=json-in-script&callback=related_results_labels' type='text/javascript'></script>
<script src='/feeds/posts/default/-/python?alt=json-in-script&callback=related_results_labels' type='text/javascript'></script>
<script src='/feeds/posts/default/-/tech?alt=json-in-script&callback=related_results_labels' type='text/javascript'></script>
<script type='text/javascript'>
var maxresults=3;
var size = 350;
removeRelatedDuplicates();
printRelatedLabels('http://www.sacralpanda.com/2017/08/how-to-become-python-coder-first-part.html');</script>
</div>
<div class='clear'></div>
<div class='greden'>
<div class='reg-bent'>
<div class='reg-bent2'>
<span id='blog-pager-newer-link'>
<span class='two-left'>Next</span><br/>
<a class='blog-pager-newer-link' href='http://www.sacralpanda.com/2017/08/bill-gates-part-of-depopulation-agenda.html' id='Blog1_blog-pager-newer-link' title='Newer Post'><i class='fa fa-chevron-left'></i> Prev Post</a>
</span>
</div>
</div>
<div class='fed-bent'>
<div class='fed-bent2'>
<span id='blog-pager-older-link'>
<span class='two-left'>Previous</span><br/>
<a class='blog-pager-older-link' href='http://www.sacralpanda.com/2017/08/brazilian-man-gets-dog-face.html' id='Blog1_blog-pager-older-link' title='Older Post'>Next Post <i class='fa fa-chevron-right'></i></a>
</span>
</div>
</div>
</div>
<div style='clear: both;'></div>
</div>
<div class='auth-panel'>
<img alt='Oltjano' class='author_avatar' height='96' src='//2.bp.blogspot.com/-ZmJPJLcOx90/WWTI-6i8gwI/AAAAAAAACdA/IYB6nmS1FdUxAWNHuHw79tSu390TbvbgQCK4BGAYYCw/s113/buda.jpg' width='96'/>
<h4>About Oltjano</h4>
<p>

I am a lightworker focused on personal development and self love. I believe that the more I grow spiritually the more I help myself and others. Love and Light!
</p>
</div>
</div>
</div>
<div class='comments' id='comments'>
<a name='comments'></a>
<h5><i class='fa fa-comments-o' style='font-size:18px;'></i>
No comments:</h5>
<a class='buffer' href='#comment-editor'>Write comments</a>
<div class='comments-content'>
<script async='async' src='' type='text/javascript'></script>
<script type='text/javascript'>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</script>
<div id='comment-holder'>
<!--Can't find substitution for tag [post.commentHtml]-->
</div>
</div>
<p class='comment-footer'>
<div class='comment-form'>
<a name='comment-form'></a>
<p>
</p>
<a href='https://www.blogger.com/comment-iframe.g?blogID=3019166093343777824&postID=7647189486764722753' id='comment-editor-src'></a>
<iframe allowtransparency='true' class='blogger-iframe-colorize blogger-comment-from-post' frameborder='0' height='410px' id='comment-editor' name='comment-editor' src='' width='100%'></iframe>
<!--Can't find substitution for tag [post.friendConnectJs]-->
<script src='https://www.blogger.com/static/v1/jsbin/569042235-comment_from_post_iframe.js' type='text/javascript'></script>
<script type='text/javascript'>
      BLOG_CMT_createIframe('https://www.blogger.com/rpc_relay.html');
    </script>
</div>
</p>
<div id='backlinks-container'>
<div id='Blog1_backlinks-container'>
</div>
</div>
</div>
</div>

        </div></div>
      
</div>
<div class='post-feeds'>
<div class='feed-links' style='display:none;'>
Subscribe to:
<a class='feed-link' href='http://www.sacralpanda.com/feeds/7647189486764722753/comments/default' target='_blank' type='application/atom+xml'>Post Comments (Atom)</a>
</div>
</div>
<script type="text/javascript">window.___gcfg = {'lang': 'en'};</script>
</div></div>
<aside>
</aside>
<div style='clear: both'></div>
<footer>
</footer>
</div><!-- main-inner-wrap -->
</div><!-- /main-wrapper -->
<div class='sidebar-wrapper'>
<div class='sidebar section' id='sidebar1'><div class='widget HTML' data-version='1' id='HTML9'>
<div class='widget-content'>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Mercedes Benz banner Responsive -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7300728982462487"
     data-ad-slot="1335761120"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div class='clear'></div>
<span class='widget-item-control'>
<span class='item-control blog-admin'>
<a class='quickedit' href='//www.blogger.com/rearrange?blogID=3019166093343777824&widgetType=HTML&widgetId=HTML9&action=editWidget&sectionId=sidebar1' onclick='return _WidgetManager._PopupConfig(document.getElementById("HTML9"));' target='configHTML9' title='Edit'>
<img alt='' height='18' src='https://resources.blogblog.com/img/icon18_wrench_allbkg.png' width='18'/>
</a>
</span>
</span>
<div class='clear'></div>
</div><div class='widget FollowByEmail' data-version='1' id='FollowByEmail2'>
<h2 class='title'>Follow by Email</h2>
<div class='widget-content'>
<div class='follow-by-email-inner'>
<form action='https://feedburner.google.com/fb/a/mailverify' method='post' onsubmit='window.open("https://feedburner.google.com/fb/a/mailverify?uri=SpiritualPanda", "popupwindow", "scrollbars=yes,width=550,height=520"); return true' target='popupwindow'>
<table width='100%'>
<tr>
<td>
<input class='follow-by-email-address' name='email' placeholder='Email address...' type='text'/>
</td>
<td width='64px'>
<input class='follow-by-email-submit' type='submit' value='Submit'/>
</td>
</tr>
</table>
<input name='uri' type='hidden' value='SpiritualPanda'/>
<input name='loc' type='hidden' value='en_US'/>
</form>
</div>
</div>
<span class='item-control blog-admin'>
<div class='clear'></div>
<span class='widget-item-control'>
<span class='item-control blog-admin'>
<a class='quickedit' href='//www.blogger.com/rearrange?blogID=3019166093343777824&widgetType=FollowByEmail&widgetId=FollowByEmail2&action=editWidget&sectionId=sidebar1' onclick='return _WidgetManager._PopupConfig(document.getElementById("FollowByEmail2"));' target='configFollowByEmail2' title='Edit'>
<img alt='' height='18' src='https://resources.blogblog.com/img/icon18_wrench_allbkg.png' width='18'/>
</a>
</span>
</span>
<div class='clear'></div>
</span>
</div></div>
<div class='threetabs'>
<ul class='tabber wrap-tabs'>
<li class='keez'><a href='#id2'>Popular Posts</a></li>
<li class='keez'><a href='#id3'>Comments</a></li>
<li class='keez'><a href='#id4'>Category</a></li>
</ul>
<div class='clear'></div>
<div class='boner' id='id2'>
<div class='sidebar section' id='popular-post'><div class='widget PopularPosts' data-version='1' id='PopularPosts2'>
<h2>Popular Posts</h2>
<div class='widget-content popular-posts'>
<ul>
<li>
<div class='item-content'>
<div class='item-thumbnail'>
<a href='http://www.sacralpanda.com/2017/08/video-man-arrested-for-breaking-laws-of.html'>
<img alt='' border='0' height='72' src='https://1.bp.blogspot.com/-8I5RRNyOuWY/WYh5DX4RQjI/AAAAAAAAC2E/24B-7F3B000IuAxIZvrkWDSIQUFxaY8VgCLcBGAs/s72-c/busted.png' width='72'/>
</a>
</div>
<div class='item-title'><a href='http://www.sacralpanda.com/2017/08/video-man-arrested-for-breaking-laws-of.html'>Video, man arrested for breaking the laws of gravity</a></div>
<div class='item-snippet'>   A guy well known on the internet for his levitating skills has been arrested by the police while practicing on the beach without harming ...</div>
</div>
<div style='clear: both;'></div>
</li>
<li>
<div class='item-content'>
<div class='item-thumbnail'>
<a href='http://www.sacralpanda.com/2017/08/man-becomes-ken-doll.html'>
<img alt='' border='0' height='72' src='https://1.bp.blogspot.com/-Y8YPi2weIW8/WY2if4ZRkZI/AAAAAAAAC6Y/SIUMsmo7HXQSXrUqrg0aAgTzpKValRUsQCLcBGAs/s72-c/ken.jpg' width='72'/>
</a>
</div>
<div class='item-title'><a href='http://www.sacralpanda.com/2017/08/man-becomes-ken-doll.html'>Man becomes a Ken doll</a></div>
<div class='item-snippet'>     Rodrigo Alves, a show man in United Kingdom, &#160;has gone through 50 cosmetic surgeries to look like the Ken doll from Barbie and Ken. Dur...</div>
</div>
<div style='clear: both;'></div>
</li>
<li>
<div class='item-content'>
<div class='item-thumbnail'>
<a href='http://www.sacralpanda.com/2017/07/video-mom-and-her-son-change-gender.html'>
<img alt='' border='0' height='72' src='https://1.bp.blogspot.com/-vWqtomOuHZs/WXnqvDrM0PI/AAAAAAAACqE/IbjKWgInx4MdQGkWftFlFiFkRihC-u3MgCLcBGAs/s72-c/0.jpg' width='72'/>
</a>
</div>
<div class='item-title'><a href='http://www.sacralpanda.com/2017/07/video-mom-and-her-son-change-gender.html'>Video, mom and her son change gender</a></div>
<div class='item-snippet'>    As we move to the new Earth, many people experiment with their self without the fear of being judged by others. The spiritual awakening ...</div>
</div>
<div style='clear: both;'></div>
</li>
<li>
<div class='item-content'>
<div class='item-thumbnail'>
<a href='http://www.sacralpanda.com/2017/08/blue-whale-suicide-game-creator-calls.html'>
<img alt='' border='0' height='72' src='https://2.bp.blogspot.com/-h6lgdxXlQSc/WYhhFDdXVDI/AAAAAAAAC14/D5qvnoLAp7IiBBBHmacQz8uBkmrqWhoJACEwYBhgL/s72-c/sd.jpg' width='72'/>
</a>
</div>
<div class='item-title'><a href='http://www.sacralpanda.com/2017/08/blue-whale-suicide-game-creator-calls.html'>Blue Whale suicide game creator calls his victims biological waste</a></div>
<div class='item-snippet'>     Blue Whale is an online game which is getting a lot of attention for the fact it has taken lives of so many teenagers who played it. Th...</div>
</div>
<div style='clear: both;'></div>
</li>
<li>
<div class='item-content'>
<div class='item-thumbnail'>
<a href='http://www.sacralpanda.com/2017/07/signs-you-are-getting-out-of-matrix.html'>
<img alt='' border='0' height='72' src='https://4.bp.blogspot.com/-o57tsMCrP4I/WWTcpO2S6lI/AAAAAAAACeQ/_27w_9QLPfUUt7YCGfSTkZ_k3NrEz-T_ACLcBGAs/s72-c/matrix.jpg' width='72'/>
</a>
</div>
<div class='item-title'><a href='http://www.sacralpanda.com/2017/07/signs-you-are-getting-out-of-matrix.html'>Signs you are getting out of the matrix</a></div>
<div class='item-snippet'>     The Matrix   Most of the people live a programmed life which is based on very old templates that carry different instructions on how ot...</div>
</div>
<div style='clear: both;'></div>
</li>
</ul>
<div class='clear'></div>
<span class='widget-item-control'>
<span class='item-control blog-admin'>
<a class='quickedit' href='//www.blogger.com/rearrange?blogID=3019166093343777824&widgetType=PopularPosts&widgetId=PopularPosts2&action=editWidget&sectionId=popular-post' onclick='return _WidgetManager._PopupConfig(document.getElementById("PopularPosts2"));' target='configPopularPosts2' title='Edit'>
<img alt='' height='18' src='https://resources.blogblog.com/img/icon18_wrench_allbkg.png' width='18'/>
</a>
</span>
</span>
<div class='clear'></div>
</div>
</div></div>
</div>
<div class='boner' id='id3'>
<script src='/feeds/comments/default?alt=json&callback=ms_recent&&max-results=50' type='text/javascript'></script>
</div>
<div class='boner' id='id4'>
<div class='sidebar section' id='Category'><div class='widget Label' data-version='1' id='Label3'>
<h2>Labels</h2>
<div class='widget-content list-label-widget-content'>
<ul>
<li>
<a dir='ltr' href='http://www.sacralpanda.com/search/label/alien'>
alien
</a>
</li>
<li>
<a dir='ltr' href='http://www.sacralpanda.com/search/label/awakening'>
awakening
</a>
</li>
<li>
<a dir='ltr' href='http://www.sacralpanda.com/search/label/conspiracy'>
conspiracy
</a>
</li>
<li>
<a dir='ltr' href='http://www.sacralpanda.com/search/label/fitness'>
fitness
</a>
</li>
<li>
<a dir='ltr' href='http://www.sacralpanda.com/search/label/growth'>
growth
</a>
</li>
<li>
<a dir='ltr' href='http://www.sacralpanda.com/search/label/Linux'>
Linux
</a>
</li>
<li>
<a dir='ltr' href='http://www.sacralpanda.com/search/label/mercedes_benz'>
mercedes_benz
</a>
</li>
<li>
<a dir='ltr' href='http://www.sacralpanda.com/search/label/politics'>
politics
</a>
</li>
<li>
<a dir='ltr' href='http://www.sacralpanda.com/search/label/spiritual'>
spiritual
</a>
</li>
<li>
<a dir='ltr' href='http://www.sacralpanda.com/search/label/tech'>
tech
</a>
</li>
<li>
<a dir='ltr' href='http://www.sacralpanda.com/search/label/twinflames'>
twinflames
</a>
</li>
<li>
<a dir='ltr' href='http://www.sacralpanda.com/search/label/weird'>
weird
</a>
</li>
<li>
<a dir='ltr' href='http://www.sacralpanda.com/search/label/windows'>
windows
</a>
</li>
</ul>
<div class='clear'></div>
<span class='widget-item-control'>
<span class='item-control blog-admin'>
<a class='quickedit' href='//www.blogger.com/rearrange?blogID=3019166093343777824&widgetType=Label&widgetId=Label3&action=editWidget&sectionId=Category' onclick='return _WidgetManager._PopupConfig(document.getElementById("Label3"));' target='configLabel3' title='Edit'>
<img alt='' height='18' src='https://resources.blogblog.com/img/icon18_wrench_allbkg.png' width='18'/>
</a>
</span>
</span>
<div class='clear'></div>
</div>
</div></div>
</div>
</div>
<div class='clear'></div>
<div class='sidebar section' id='sidebar'><div class='widget HTML' data-version='1' id='HTML8'>
<div class='widget-content'>
<iframe src="https://www.facebook.com/plugins/page.php?href=https%3A%2F%2Fwww.facebook.com%2Fprofile.php%3Fid%3D131016297498635&tabs&width=300&height=200&small_header=true&adapt_container_width=true&hide_cover=false&show_facepile=true&appId" width="300" height="200" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowtransparency="true"></iframe>
</div>
<div class='clear'></div>
<span class='widget-item-control'>
<span class='item-control blog-admin'>
<a class='quickedit' href='//www.blogger.com/rearrange?blogID=3019166093343777824&widgetType=HTML&widgetId=HTML8&action=editWidget&sectionId=sidebar' onclick='return _WidgetManager._PopupConfig(document.getElementById("HTML8"));' target='configHTML8' title='Edit'>
<img alt='' height='18' src='https://resources.blogblog.com/img/icon18_wrench_allbkg.png' width='18'/>
</a>
</span>
</span>
<div class='clear'></div>
</div><div class='widget HTML' data-version='1' id='HTML7'>
<div class='widget-content'>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:350px"
     data-ad-client="ca-pub-7300728982462487"
     data-ad-slot="3509185939"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div class='clear'></div>
<span class='widget-item-control'>
<span class='item-control blog-admin'>
<a class='quickedit' href='//www.blogger.com/rearrange?blogID=3019166093343777824&widgetType=HTML&widgetId=HTML7&action=editWidget&sectionId=sidebar' onclick='return _WidgetManager._PopupConfig(document.getElementById("HTML7"));' target='configHTML7' title='Edit'>
<img alt='' height='18' src='https://resources.blogblog.com/img/icon18_wrench_allbkg.png' width='18'/>
</a>
</span>
</span>
<div class='clear'></div>
</div><div class='widget HTML' data-version='1' id='HTML3'>
<h2 class='title'>Featured Video</h2>
<div class='widget-content'>
<iframe width="300" height="200" src="https://www.youtube.com/embed/AEYKtUqNxwY" frameborder="0" allowfullscreen></iframe>
</div>
<div class='clear'></div>
<span class='widget-item-control'>
<span class='item-control blog-admin'>
<a class='quickedit' href='//www.blogger.com/rearrange?blogID=3019166093343777824&widgetType=HTML&widgetId=HTML3&action=editWidget&sectionId=sidebar' onclick='return _WidgetManager._PopupConfig(document.getElementById("HTML3"));' target='configHTML3' title='Edit'>
<img alt='' height='18' src='https://resources.blogblog.com/img/icon18_wrench_allbkg.png' width='18'/>
</a>
</span>
</span>
<div class='clear'></div>
</div><div class='widget ContactForm' data-version='1' id='ContactForm1'>
</div></div>
</div><!-- sidebar-wrapper -->
<div class='clear'></div>
</div><!--Div Container-->
</div><!-- outer-wrapper -->
<div id='footer'>
<div class='mage1'>
<div class='container'>
<div class='footer boxer lefter section' id='footer1'><div class='widget HTML' data-version='1' id='HTML6'>
<script type='text/javascript'>
var disqus_shortname = 'sacralpanda-com';
var disqus_blogger_current_url = "http://www.sacralpanda.com/2017/08/how-to-become-python-coder-first-part.html";
if (!disqus_blogger_current_url.length) {
disqus_blogger_current_url = "http://www.sacralpanda.com/2017/08/how-to-become-python-coder-first-part.html";
}
var disqus_blogger_homepage_url = "http://www.sacralpanda.com/";
var disqus_blogger_canonical_homepage_url = "http://www.sacralpanda.com/";
</script>
<style type='text/css'>
#comments {display:none;}
</style>
<script type='text/javascript'>
(function() {
    var bloggerjs = document.createElement('script');
    bloggerjs.type = 'text/javascript';
    bloggerjs.async = true;
    bloggerjs.src = '//' + disqus_shortname + '.disqus.com/blogger_item.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(bloggerjs);
})();
</script>
<style type='text/css'>
.post-comment-link { visibility: hidden; }
</style>
<script type='text/javascript'>
(function() {
var bloggerjs = document.createElement('script');
bloggerjs.type = 'text/javascript';
bloggerjs.async = true;
bloggerjs.src = '//' + disqus_shortname + '.disqus.com/blogger_index.js';
(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(bloggerjs);
})();
</script>
</div>
</div>
<div class='footer boxer lefter tagcloud1 no-items section' id='footer2'></div>
<div class='footer boxer lefter section' id='footer3'><div class='widget HTML' data-version='1' id='HTML4'>
<h2 class='title'>About Us</h2>
<div class='widget-content'>
Hi,

I am Spiritual Panda. I have passed through a lot of darkness to understand that I am my own light. Now that I am learning to love myself without conditions, I have come to the conclusion that the time to serve others has arrived. Using this website, Spiritual Panda is going to inform the souls all over the world about the spiritual journey, all things above and below.

I want to change the world by becoming the best version of myself. By becoming the true love I am!

Love and Light.
</div>
<div class='clear'></div>
<span class='widget-item-control'>
<span class='item-control blog-admin'>
<a class='quickedit' href='//www.blogger.com/rearrange?blogID=3019166093343777824&widgetType=HTML&widgetId=HTML4&action=editWidget&sectionId=footer3' onclick='return _WidgetManager._PopupConfig(document.getElementById("HTML4"));' target='configHTML4' title='Edit'>
<img alt='' height='18' src='https://resources.blogblog.com/img/icon18_wrench_allbkg.png' width='18'/>
</a>
</span>
</span>
<div class='clear'></div>
</div></div>
<div class='clear'></div>
</div><!--Div Container-->
</div><!-- mage1 -->
</div><!-- footer -->
<div class='footer-credits'>
<div class='mage2'>
<div class='container'>
<div class='attribution'>&#169; Copyright 2015 <a href='http://www.sacralpanda.com/'>sacralpanda</a>. <span id='credit'></span>. <span class='deen'>Powered by <a href='https:blogger.com/'>Blogger</a>.</span>
</div>
</div>
</div><!-- mage2 -->
</div><!-- footer-credits -->
</div><!-- ct-wrapper -->
<div id='fb-root'></div>
<script type='text/javascript'>
//<![CDATA[

//Facebook Script
(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src="//connect.facebook.net/en_US/all.js#xfbml=1";fjs.parentNode.insertBefore(js,fjs)}(document,'script','facebook-jssdk'));

//]]>
</script>
<!-- Page Counter - Edit Number Of Post To Show On Each Page -->
<script type='text/javascript'>
$(document).ready(function(){
var olderLink = $("a.blog-pager-older-link").attr("href");
$("a.blog-pager-older-link").load(olderLink+" .post-title:first", function() {
var olderLinkTitle = $("a.blog-pager-older-link:first").text();
$("a.blog-pager-older-link").text(olderLinkTitle);//rgt
});
var newerLink = $("a.blog-pager-newer-link").attr("href");
$("a.blog-pager-newer-link").load(newerLink+" .post-title:first", function() {
var newerLinkTitle = $("a.blog-pager-newer-link:first").text();
$("a.blog-pager-newer-link").text(newerLinkTitle);
});
});

</script>
<script src='https://apis.google.com/js/plusone.js' type='text/javascript'></script>

<script type="text/javascript" src="https://www.blogger.com/static/v1/widgets/2582377541-widgets.js"></script>
<script type='text/javascript'>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</script>
</body>
</html>